FrontPage

手の骨を追加する

β2.05で、手の骨を追加する機能が入りました。
その機能について説明します。

addhandbone.jpg


まず、キャラクターが読み込まれている状態で、キャラクターエディターから追加骨タブを選びます。
そこから、手の骨を追加ボタンを押します。
そうすると、手の骨が追加されます。
メインウィンドウのメニューから、「表示」→「ボーン表示」→「基本骨」を選ぶことで骨が追加されたことを確認できます。

displaybone.jpg


外殻もついています。
「ウィンドウ」→「外殻コントロール」を選びます。
そこから、頂点とポリゴンのチェックをつけます。
そうすることで、手の外殻が追加されていることを確認できます。
必ずしも、この外殻を使う必要はありません。
この外殻は、おまけで出るようにしていますが、自分で作った外殻を使用することも可能です。

サクラや、ベッキーを使っていると、最初から手はついています。
それは、シェイプアニメーションで動いているもので骨は使用されていません。
骨を使用したものに入れ替える方法を説明します。
(以下の説明はサクラを使った場合の説明です)

余計なものの非表示

handinvisible.jpg


キャラクターエディターの表示タブから、さらにモデルタブを選びます。
もともとあるgai_te_rと、gai_te_lの上記の図にある部分をクリックします。
そうすることで、元の外殻は非表示になります。
さらに、手のタブを選びます。
元の手のモデルhand_bのチェックをはずします。
そうすると、手が非表示になります。

外殻の接続

手の外殻と体の外殻を接続する必要があります。
手と体の外殻が接続されていないと、正しくアタッチできません。
手の骨を追加したときに、同時に追加された手の外殻を選びます。
キャラクターエディターの表示タブの中のモデルタブを選びます。
その中に、gai_hand_f_r,gai_hand_f_lという2つの手の外殻があります。
それらをダブルクリックします。
ウィンドウが開いたら、ウィンドウの内容を下の方にスクロールさせて、接続タイプという項目で「現在位置」を選びます。
「エッジを近くの頂点につなげる」チェックボックスにチェックを入れます。
外殻の切れ目同士が少し離れているので、ConnectLengthの値を上げて0.2にします。
そうすることで、手と体の外殻が繋がるかと思います。
外殻同士の距離が離れている場合は、ConnectLengthの値をもっと上げてみてください。

新しい手のモデルのつけたし

外殻に似合ったモデルを用意します。

右クリックしてダウンロードしてください。
xsiファイルをメインウィンドウにドラッグアンドドロップすると、手のモデルを読み込めます。
インポートオプションはデフォルトのままでOKです。
モデルをつける前に、キャラクターをTポーズにします。
さらに、アニメーションエディターのオフセットタブの下の方にある、伸びきり防止のチェックをはずします。
キャラクターエディターの、骨の長さタブから、手の大きさを1にします。
その状態だと、サクラの場合ちょうど外殻とモデルの位置が合うと思います。

手のモデルを、キャラクターの一部になるように移動させます。
下記の図のように、モデルコントロールから手のモデルを、キャラクターエディターの表示タブの中の手のタブにドラッグアンドドロップで移動させます。

movehandmodel.jpg


移動させたら、その手をダブルクリックします。
ウィンドウが現れるので、LaAttach?ボタンを押します。
アタッチには時間がかかるので待ちます。
筆者のPCの場合は、47秒かかりました。
アタッチが終わると、外殻によってモデルが動くようになります。

手のマテリアルと接続

手と体のマテリアルを合わせたいと思います。

キャラクターエディターの表示タブから、体のタブを選びます。
body8というモデルをダブルクリックしてマテリアルコピーを選びます。
詳しくは図のように、体のマテリアルを選びコピーして、手のマテリアルに貼り付けます。

materialcopy.jpg


次に、手のモデルを接続します。
少し、手と体のモデルが離れてしまっていると思います。
体のマテリアルエディターが開いていると思うので、そのまま全般タブを選びます。
ウィンドウの内容を下の方にスクロールさせると、接続タイプの項目があります。
接続タイプは、現在位置を選びましょう。
そうすることで、繋がるはずです。
接続タイプは基本的に、現在位置を使います。
変形前やその他の項目は、古いデータとの互換のために残してあります。

手の制御

以上の手順を行うことで、手の制御が可能になります。
sakura_handbone4.avt

一応、サクラに関して上記の手順を行ったデータが、これになります。
ここまでできたら、手の制御を行うことができます。
手の骨を追加したときに出てくるウィンドウからポーズタブを選びます。
ウィンドウを消してしまった場合は、キャラクターエディターの追加骨の追加骨リストから項目を選び、編集ボタンを押します。
ポーズタブでは、手のサムネイルが表示されていると思います。
まず、右手、左手の項目を選んでから、サムネイルを選びます。
それから、ポーズ適用することで手が変形するはずです。

handpose.jpg


ポーズを選択して、キーフレームボタンを押すと、手のポーズのキーフレームを打つことができます。
フレーム指定して、ポーズを選んでキーフレームを押します。
フレームを変更して、ポーズを選んでキーフレームを押します。
それを繰り返していくことで、一連のモーションを作ることができます。
アニメーション削除ボタンを押すと、モーションを削除してやり直すことができます。
デフォルトポーズを押すと、手の基本形状に戻ります。
ミラーボタンを押すと、左右の手のモーションが反転します。

ポーズの追加

アニメーションエディターで、その他の編集をすると手の形状を変えることができます。
手にある△マークをクリックして各指の関節を曲げることができます。
各関節は、だいたいZ軸回転に制限されています。
各指の付け根の△を押すと、根元はXYZ全ての方向に回転できます。
滅多に必要ではないと思いますが、ポーズタブにあるZ軸回転に制限のチェックをはずすと、各関節に関してもXYZ回転が可能になります。
手の形状が出来上がったら、手が良い感じに見えるようにSキーを押してカメラを動かします。
それから、ポーズの追加ボタンを押します。
そうすると、名前を入れるダイアログがでるので、似合った名前をつけます。
現在画面に表示されている画像を元にサムネイルつきで、ポーズが登録されます。
このデータは、LAスタジオのDataフォルダ内のHandフォルダに保存されます。
他のキャラクターに対しても同じ手のポーズが設定できるようになります。
ポーズを修正して上書きすることもできます。
上書きしたいポーズを選んでから、上書きボタンを押します。
サムネイルも作り直されます。

関節タブに関して

関節タブでは、関節を曲げたときの外殻形状の調整ができます。
普通のCGソフトで、各指の関節3本として、5本の指があるので15本の骨を入れてエンベロープ付け(スキニング)しただけで指を曲げた場合、手の形状をグーの形に握らせると指の形状が破綻してしまうと思います。
なのでLAスタジオでは、各関節に補間用の骨を追加して、さらに曲がり具合に応じて動きを調整できるようにしました。
変形開始角度のパラメータは、関節をどれだけ曲げたら補間用の骨が特殊な変形をするかを決められます。
曲がり移動のパラメータでは、関節が曲がる方向に対して補間用の骨を移動させる量を決められます。
曲がりスケールでは、関節を曲げたときの補間用の骨のスケーリング値を決められます。
曲げたときに指が、どういう形状になるかある程度制御できます。

右指、左指の骨の長さ

デフォルトの外殻を使用しない場合に使用します。
指の長さ、各関節の根元の位置などを指定できます。
そうすることで、手の骨を作成できます。
手の大きさを変えるだけであれば、ここのパラメータは使う必要はありません。
キャラクターエディターの骨の長さタブの、手の大きさパラメータを使用して大きさを変えてください。



添付ファイル: filedisplaybone.jpg 327件 [詳細] fileaddhandbone.jpg 310件 [詳細] filehandpose.jpg 294件 [詳細] filematerialcopy.jpg 275件 [詳細] filehandinvisible.jpg 306件 [詳細] filesakura_hand2.xsi 399件 [詳細] filemovehandmodel.jpg 287件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2015-05-25 (月) 22:01:55 (730d)